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1. Introduction 
 

Reducing Emissions from Deforestation and Forest Degradation (REDD) is an effort to create a 

financial value for the carbon stored in forests, offering incentives for developing countries to reduce 

emissions from forested lands and invest in low-carbon paths to sustainable development. "REDD+" 

goes beyond deforestation and forest degradation, to include the role of conservation, sustainable 

management of forests and enhancement of forest carbon stocks. This will involve changing the ways 

in which forests are used and managed, and may require many different actions, such as protecting 

forests from fire or illegal logging or rehabilitating degraded forest areas. 

 

REDD+ has the potential to deliver multiple benefits beyond carbon. For example, it can promote 

biodiversity conservation and secure ecosystem services from forests such as water regulation, 

erosion control and non-timber forest products. Some of the potential benefits from REDD+, such as 

biodiversity conservation, can be enhanced through identifying areas where REDD+ actions might 

have the greatest impact using spatial analysis. 

 
This tutorial demonstrates how a species richness grid could be created using species range data from 

the IUCN Red List (IUCN, 2013). It provides full instructions of how to select and analyze and export 

information from the non-spatial species data on the IUCN Red List website and how to further 

analyze the information along- side the IUCN spatial data using ArcGIS 10.x. 

 
 

2. Using IUCN Red List species data and generating species richness maps 

2.1. Selecting and downloading species data from the IUCN Red List website  
 

The IUCN Red List of Threatened Species website allows users to search for and extract tabular 

information (in comma separated values (CSV) file format) on the status of threatened species. The 

website provides a user friendly interface and gives the user flexibility to customize searches based on 

a range of criteria. Users must register with the website to save and export customized searches. 

2.1.1. Searching for non-spatial data 

Open a web browser and go to the IUCN Red List website at http://www.iucnredlist.org/. 

This search below is an EXAMPLE search for Mammals with threat status of Critically Endangered (CR) 

and Endangered (EN). 

  

http://www.iucnredlist.org/
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a. Click on Other 

Search Options 

 
 

b. Click on Taxonomy 

 

c. Expand ANIMALIA 

d. Expand CHORDATA 

e. Tick AMPHIBIA, 

AVES and MAMMALIA,  

f. Press the arrow key to send the 

selection across to the Your Search 

Criteria panel 

You may want to limit the 

search to a single location e.g. 

a single country or group of 

locations only. 

g.  Click on Location,  expand 

land regions, expand and tick 

the country of interest  

h. Press the arrow key to send 

the selection across to the 

Your Search Criteria panel 

 

 

i. Next Click on Assessment 

j. Untick categories not required  

i.e. in this example unticking 

 EX and EW and keeping the rest. 

 

k. Press the arrow key to send the 

selection across to the Your Search 

Criteria panel   

     

l. Click Run search 

 
This search will result in a list of species within the AMPHIBIA, AVES and MAMMALIA taxonomic groups 

that have critically endangered, Endangered, Vulnerable, Lower Risk: Conservation Dependent, Near 

Threatened, Data Deficient or Least Concern Red List status. The search will produce in a list of species 

containing and additional attribute data, including the threat status of each of the species.  
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There are other criteria that you may want to include. For example, to limit the search to species 

dependent upon a particular habitat type you would click on Habitat, the expand and tick the relevant 

habitat type and send that across to the search criteria panel. 

2.1.2. Save the search and exporting to CSV format 
 

 
a. Click  

Save/Export Search 

 
b. If already registered, 

 fill in your email address 

  and password and click 

  login 

 

c. If you have not yet 

 registered, you need 

 to create  an 

  account  

  (see box below) 

 

An account is  

needed in order to 

save and export  

the search results. 

 

 

d. New users will be asked to 

 fill out the details in the 

 box below 

  

The first time new users export a search, 

they are required to fill out some information 

about themselves and the intended use of 

the data 

 

 

Click on Supply your  

information and fill in the requested details 

 

Click on Submit 

 

 

 

 



Using GIS software to support REDD+ planning 

 

4 

e. Once registered and/or  

logged in, Click on Add your 

currentSearch 

 

 

 

 

f. Give the search a name 

e.g. NGA_AmpAveMam in this 

example 

  

 

g. Click add to saved searches 

 

 

h. Click on the saved search e.g. 

NGA_AmpAveMam in this 

example 

 

 

i. Scroll down to Export results 

  and click on Export results 

  

The dataset will then give a 

status of Queued for export. 

  

 

  

 

 

An email will be sent to you once it has 

been exported. This is usually within 

minutes but may take hours for large 

searches). 

 

 

j. Refresh the browser to see the status change to show the export is complete or if it is taking 

a long time log out and once the email  has been received, log back in to the Red List website  

and click on the My Downloads Tab to get back to your saved searches. 
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k.  Click on the exported search  

  e.g. NGA_AmpAveMam in this 

  example 

 

 
 

l. Scroll down to the Export results 

 

m. Click on Comma-Separated Values (CSV) 

  and the zip file will download 

 

n. If the download has placed the file in a 

  general download folder move the zip 

  file to a more suitable location e.g. in a  

 project folder 

o. Rename the zip file to somthing sensible 

 e.g. NGA_AmpAveMam.zip  in this 

  example 

p. Right click on zip folder, extract the csv 

  file 

 

q. Rename the csv file e.g. NGA_AmpAveMam.csv in this example 

2.1.3. Download the IUCN Red List spatial data layers 

The next steps are for downloading spatial data. It is only possible to download the whole global 

dataset. It is not possible to filter by county prior to download. It is important to note that some of the 

spatial datasets are very large. If you have received the spatial data directly from IUCN you can skip 

this section. 

a. Open a web browser and go to the IUCN  Red List website at 

  http://www.iucnredlist.org/ 

b. From the Resources tab, click on Spatial Data Download 

 

 

 

 

 

 

 

 

 

 

http://www.iucnredlist.org/
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c. Scroll down on the Spatial Data page to the Datasets table  

 

 

 

 

 

 

 

d. Click the links to navigate to each dataset and download the following global datasets: 

 Mammals 

 Amphibians 

 Birds (via the link to the BirdLife Data Zone) 

(Leave Reptiles for now as assessment is not yet complete for all species) 

 

These files are all stored in geographic coordinate system (EPSG: 4326). Be aware the files are 

very large and will take some time to download.  

Note: If you have received the spatial data directly from IUCN they may have delivered as a 

single geodatabase containing all taxa in a single feature class rather than as separate files. 

2.2. Vector Spatial Data Selection and Preparation 

2.2.1. Format species CSV file in preparation for querying the spatial data 

a. Open the 'exported search' results csv file (that was downloaded in section 2.3 step m) e.g. 

NGA_AmpAveMam.CSV in this example. Open the file Excel (or if using completely open 

source software in Gnumeric or Libre Office Calc) (The Screengrab examples below use Excel. 
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b. Scroll along the column headings of the table. Some will need to be changed as GIS software 

such as ArcGIS will not accept them. Change the ones listed below in red 

 OLD Field Name  New Field Name 

Species ID = Species_ID 

Kingdom = Kingdom 

Phylum = Phylum 

Class = Class 

Order = Order 

Family = Family 

Genus = Genus 

Species = Species 

Binomial = Binomial 

Authority = Authority 

Infraspecific rank = Inf_rank 

Infraspecific name = Inf_name 

Infraspecific authority = inf_auth 

Stock/subpopulation = stk_subpop 

Synonyms = Synonyms 

Common names (Eng) = com_eng 

Common names (Fre) = com_fre 

Common names (Spa) = com_spa 

Red List status = rl_status 

Red List criteria = rl_criteria 

Red List criteria version = rl_version 

Year assessed = year_ass 

Population trend = poptrend 

Petitioned = Petitioned 
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c. Click File> Save to save the file (keeping the file format as csv). If it asks if you want to keep 

the file in this format click yes 

 

Keep the CSV file open as it will be used in section 2.6 where we will use the 'species_id' 

column to prepare an SQL query to be used in ArcGIS. 

 

The next steps will prepare an SQL query which will be used in ArcGIS to select out the polygons 

from the large spatial dataset which are in the species list. This method is being used rather than 

using a 'join' to join the species list to the spatial data because the join function often fails or 

causes errors on this very large spatial dataset. 

 
d. Go back to the 'species list csv file. e.g. NGA_AmpAveMam.CSV  

Then copy and paste the Species_ID column into column B a new excel worksheet 

 

 
 

e. In row 2 of column A type "id_no" = (make sure you put a space after the equals sign as this 

is important for the SQL syntax we are creating 

f. In row2 of column C type an OR (this time make sure you put a space before the OR as this is 

important for the SQL syntax we are creating.) 

g. In row 2 of column D type =A2&B2&C2 

 
 

h. Next fill Columns A, B, C and D by 

double clicking on the bottom right hand 

corner of each cell in row 2 

 

i. Delete the entire first row so that the file 

now looks similar to the illustration 

below 

 

 

 

 

 

 

 

 

 

j. Save the worksheet for later to a new file e.g. in this example called 

formatted_for_SQL_query.xlsx and close 
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2.2.2. Use SQL query to select species of interest from spatial dataset 
 

The next section prepares the spatial data ready for analysis. The IUCN spatial dataset is a complex 

dataset as it contains many overlapping polygons for each species for the entire world. Even 

subsetting the dataset for your area of interest can be problematic so these set of instructions are 

important steps to make sure the analysis runs as smoothly as possible and to reduce the risk of 

errors in processing.  

 
a. Open ArcGIS 

b. Add in the IUCN Species spatial dataset(s) (the data are in geographic coordinate 

system (i.e. WGS84) 

 

 
 

 

c. Untick the dataset in the table of contents to stop it drawing 

d. Add in a polygon dataset of the area of interest (e.g. country boundary). e.g. in this 

example nga_border_dd.shp.  Make sure the dataset is in geographic coordinate 

system (i.e. WGS84) to match the coordinate system of the IUCN spatial data 

e. Click on the IUCN spatial dataset in the table of contents to make it the active layer 

e.g. in this example iucn_rl_species_2014_2_no_sens 

 

 
 

 



Using GIS software to support REDD+ planning 

 

10 

 
f. Right click on the IUCN spatial dataset and Click Open attribute table. Click on the top 

left button, and click select by attributes.  

 

 
 

g. A Query window appears. Copy and paste into the Query window the SQL query that 

you created earlier. This will select out only those species present in the exported 

species list 

h. Remove the OR from the last row and click Verify to check you got the syntax correct. 

This may take 5 - 10 minutes or longer depending on how many records are being 

selected.  

i. Click Apply to apply the filter to the IUCN spatial dataset. This may take 5 - 10 

minutes or longer depending on how many records are being selected.  

 

j. The attribute table will show the filtered records highlighted in blue, and the number 

of records that have been selected.  

 

 



Using GIS software to support REDD+ planning 

 

11 

 

k. Close the attribute table 

l. Right click on the IUCN spatial 

dataset and Click Data > Export 

Data 

 

 
 

m. Ensure that you are exporting the selected 

features, then save the file with a new name, e.g. 

nga_iucn_selection.shp (as file type shapefile) in this 

example and Click OK. It will ask you if you would like to 

add the new file to dataframe. Click OK.  

 

 

 

 
n. Right click and Remove the IUCN spatial dataset 

in the table of contents e.g. in this example 

remove iucn_rl_species_2014_2_no_sens 
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2.2.3. From the previous selection select out the current native species range 

a. Right click on the newly added subset species layer e.g. nga_iucn_selection.shp in this 

example and and click Open attribute table. Click on the top left button and click Select 

by Attributes.  

b.  To only include categories as advised by IUCN 

Presence  - 1 (extant); 2 (probably extant); 6 

(presence uncertain) Origin – 1 (native); 2 

(reintroduced); 5 (origin uncertain)  

 

Put the following expression into the Select by 

Attributes window:- 

("presence" = 1 OR "presence" = 2 OR 

“presence” = 6) AND ("origin" = 1 OR "origin" 

= 2 OR "origin" = 5 ) 

c. Click Apply  

d. Click Close to close the Select by Attributes 

window. 

e. As per step 2.2.2. (j), the attribute table will 

show the filtered records highlighted in blue, 

and the number of records that have been 

selected. 

f. Close the attribute table.  Right click on the 

IUCN spatial dataset e.g. 

nga_iucn_selection.shp in this example and 

Click Data > Export Data. 

g. Ensure that you are exporting the selected  

features, then save the file with a new name, 

e.g. nga_iucn_selection_PO.shp (as file type 

shapefile) in this example and Click Save. It will ask you if you would like to add the new 

file to dataframe. Click OK.  
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2.2.4. From the previous selection select out terrestrial species ranges 

a. Right click on the newly added subset species 

layer e.g. nga_iucn_selection_PO.shp in this 

example and and click Open attribute table. Click 

on the top left button and click Select by 

Attributes.  

 

b. To only include species which are terrestrial put 

the following expression into the Select by 

Attributes window: "biome_terr" = 't' 

 
 
 

 
c. Click Apply  

d. Click Close to close the Select by Attributes 

window. 

e. As per step 2.2.2. (j), the attribute table will show 

the filtered records highlighted in blue, and the 

number of records that have been selected. 

f. Close the attribute table.  Right click on the IUCN 

spatial dataset e.g. nga_iucn_selection.shp in this 

example and Click Data > Export Data. 

g. Ensure that you are exporting the selected 

features, then save the file with a new name, e.g. 

nga_iucn_selection_PO_T.shp (as file type 

shapefile) in this example and Click Save. It will 

ask you if you would like to add the new file to 

dataframe. Click OK.  
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2.2.5. Batch clip the separate species datasets to area of interest 

a. In ArcGIS go to the Search > Tools > Clip (analysis). Right click on Clip and choose Batch.  
 

 
 

b.  Click on the “Input Features” and select the first of the species range files that you want to 
clip. Click on the + symbol to add extra lines, and therefore add multiple datasets.  

 

 
 

c. In the “Clip Features” column, select the vector boundary file covering your area of 
interest.  

 
d. In the “Output Feature Class” column, right click and select Browse. Select the location 

to store your clipped files, and type a new name for each dataset e.g. clip_1.shp; 
clip_2.shp. Leave  the XY Tolerance column blank.  
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e. Click Ok. This may take some time to run, depending on the number of species ranges in 
the input files being processed.  Add the clipped species files to the ArcMap session. 

 

2.2.6. Reproject to an equal area projection 
 

In subsequent steps a planning unit layer of hexagons or squares will be generated in order to 
summarise the species range data to create a species richness map. The species range and the 
hexagon or square layer must be projected to an equal area projection (e.g. Lambert Azimuthal Equal 
Area). Using an equal area projection allows the true area of the species ranges in each planning unit 
to be calculated. Whichever projection is chosen, both the species ranges and the planning units must 
be in exactly the same projection. 
 
In this example, the data are in WGS84 (a geographic coordinate system with units in decimal 

degrees). In order to generate a planning units dataset of hexagons with a specific area, the data need 

to be projected into an equal area projection with units of meters. In the following example Lambert-

azimuthal-equal-area projection is used.  

a. In ArcGIS go to the Search > Tools > Project (data management) 

b. In the Input Dataset or Feature Class select the vector boundary file covering your 

area of interest. 

c. In the Output Dataset or Feature Class select the location to store your projected file, 

and type a new name for the dataset, in this example nga_border_la.shp. 

d. Under Output Coordinate System, click on the button to the right to set the 

projection.  

e. Click on the Globe symbol and select New > Projected Co-ordinate System  
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f. From the drop down menu, choose Lambert -azimuthal-equal-area. Set the Central 

Meridan and Latitude of Origin according to the centre point of your vector area of 

interest..(You can check the co-ordinates at the bottom right hand side of the main 

ArcGIS screen, and make a note of these). Give the projection a new name, in this 

case for example, Lambert_Azi. 

 

 
 



Using GIS software to support REDD+ planning 

 

4 

 
 

g. Click OK and then OK again, to set the projection. Click OK to run the Project tool. 
 

 
 
 

h. Add the projected vector boundary nga_border_la.shp into the dataframe. 
i.  Right click on the dataframe and select Data Frame Properties.  
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j. Click on the “Layers” folder and 
you will see the custom projection that was 
created for the vector boundary. Highlight the 
Lambert_Azimuthal_Equal_Area and click ok to 
set the dataframe from Geographic to Lambert -
Azimuthal-Equal-Area.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

k. Right click on the one of the clipped IUCN species datasets in the data viewer and 
click Click Data > Export Data. Ensure that you are saving All Features and then click 
“Use the same coordinate system as the data frame”. 

 

 
 
 

l. Save the output file with a new name, e.g. nga_iucn_selection_mammal_la.shp (as 

file type shapefile) in this example and Click Save. It will ask you if you would like to 

add the new file to dataframe. Click OK.  
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m. Repeat this step for the remaining species clipped files. Save each projected output 

file with a new name, and add these projected layers to the dataframe.  

n. Remove the Geographic versions of the datasets from the ArcMap project to reduce 

confusion. 

     

 There should now be the following files in the project :- 

 Area of interest shapefile in projected CRS (e.g. TZAcountry_la.shp) 

 Clipped species shapfile in projected CRS (e.g. Mam_la.shp)  

 

2.2.7. Batch dissolve and convert to single part features 

a. Use the Dissolve tool to dissolve the IUCN species range dataset based on the species id or 
binomial field.  In ArcGIS go to the Search > Tools > Dissolve (data management). Right click 
on Dissolve and choose Batch.  
 
 
 

 
 
b. Click on the “Input Features” and select the first of the species range files that you want to 

dissolve. Click on the + symbol to add extra lines, and therefore add multiple datasets. 
 

c. In the “Output Feature Class” column, right click and select Browse. Select the location to 
store your clipped files, and type a new name for each dataset e.g. 
nga_iucn_selection_mammal_la_dis.shp 

 
d. In the Dissolve Field(s) select binomial 

 
e. In Create multipart features select True 

 
f. Leave the remaining fields as they are.  
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g. The output datasets attribute tables should contain one attribute row per species e.g:  
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2.2.8. Check the clipped and projected IUCN species range data for topological errors 

Check for topological errors in the projected IUCN and the country boundaries shapefiles data as 
these could prevent the subsequent analysis tools from  working correctly. 
 

a. In ArcGIS go to the Search > Tools > Check Geometry. Run for each dataset. 

(Remember to click OK to run the tool) 

 

 
 
b. A table will be produced which reports the errors in each of the files. In this example 

the species ranges polygons have some errors: 
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c. For each file in which there are geometry errors reported, go to Search > Tools > 

Repair Geometry.  This tool inspects each feature in a feature class for geometry 

problems. Upon discovery of a geometry problem, a relevant fix will be applied, and a 

one line description will be printed identifying the feature as well as the problem 

encountered.  The tool will continue to run through all records until geometry errors 

are resolved.  

 

 
 

d. Under the Geometry tab > Results, open the results of the ArcMap session. By 
expanding the results of the Repair Geometry tool, you can see the errors 
encountered in the data and the fix applied by the tool.  

 
 
 
Run the check and repair geometry tools on each of 

the vector files so that all geometry errors are 

resolved.  
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3. Generate a dataset of hexagons or squares 
 
a. Download the Repeating shapes 10 tool from 

http://www.jennessent.com/arcgis/repeat_shapes.htm and follow their instructions for 
installation. 

 
Make sure you don’t have any ArcGIS applications open on your machine while installing. 
Install on your machine by double clicking on repeat_shapes_10.exe 

 

If it fails the first time (as in the dialog below) 
 

 
 

 Go to your installed folder in your programme folder. 
 

http://www.jennessent.com/arcgis/repeat_shapes.htm
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 Right click on Make batch files.exe and run as administrator. 
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 Once you have done this,new files have been created one of which is 
Register_Repeating_Shapes.bat, double click on it. 

 
 Now go to step c and to try adding the tool to ArcMap. This time you should be 

able to see it. 
 

 
b. You should see: 

 

 
 
c. Open ArcMap.  

 
d. If you cannot see the Repeating shapes tool, click on Customize > Toolbars > Customize. 
 
e. Click on Commands. 
 
f. Scroll down and click on Jenness Enterprises. 
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g. Drag the repeating shapes tool and place it somewhere on your toolbars. 
h. Click Close. 
 
i. Click on the repeating shapes tool button. 
 

 
 
j. Click the extent of a particular layer. 
 
k. Click Next. 
 

 
 
l. Click on the vector file of the country boundary e.g. nga_border_la (i.e. the one that you 

saved in the equal area projection), so that it is highlighted in blue. 
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m. Click Next. 
 

 
 
n. Choose the shapes you want to use e.g. hexagons. 
 
o. Choose size of hexagons  (the units will be in map units i.e. meters) 

e.g. area 10000000 (for 10km2 dataset). 
 

 
p. Click OK. The tool will run and generate a grid of 

hexagons over the full extent of the specified input file. If 
it generates a grid that covers beyond the extent of the 
vector boundary, as in the example below, then simply clip 
the hexagon file to the vector boundary using the Clip tool.  

 

 
** Zoom into the Hexagons layer to see 
the shapes: 
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3.1. Use Hawths Analysis tools to generate species richness 
 

a. Download  Hawths Analysis tools from 
http://www.spatialecology.com/htools/tooldesc.php  
 

 ***IMPORTANT NOTE: the documentation for Hawths tools states that it will not work for 
 ArcGIS 10.x. However it will work. Install the tool as instructed. At the end it will say that it 
 has not installed correctly. Ignore this message and continue to step b. 

 
b. Click on Customize - Toolbars – Customize. 
c. Click on Add from file and navigate to C:\Program Files\HawthsTools. 

 

 
 

d. Click on Hawthstools3.dll and click open. 
e. Say yes to any messages asking if you want to allow it to install. You should then see 

following screen. 
 

 
 

f. Click OK. 
g. Click Close. 
h. Click Customize > Toolbars > Hawths Tools. 
i. From the Hawth's tools menu bar, Click on Hawthstools > Analysis Tools > Enumerate 

Intersecting Features. 
 

http://www.spatialecology.com/htools/tooldesc.php
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j. The entity layer is the hexagons shapefile. Select “Unique_ID” under the Unique ID field. 
 

k. The Enumeration feature layer is the final species spatial data in equal area projection 
that has been checked and cleaned for geometry errors. e.g. 
nga_iucn_selection_mammal_la_dis.shp. The Enumeration field is the binomial. 
 

l. Select Intersects as the geometry overlap rule.  
 

m. Choose the output location and new name for the output .csv file. 
 

n. Chose whether to tick to include hexagons containing 0 features or exclude them. 
o. Click OK. 

 
Be patient! - This will likely take a long time to run (dependent upon the size of the study 
area, and number of species) but will eventually produce a new output .csv file containing 
a list of hexagon unique id’s, the number of species it has intersected and which species 
these are. 

 
p. The output  .CSV file can be opened in Excel. 

 
q. Make a copy of the sheet which just includes the Unique_ID and number of species. 

 
r. Save as a new .xlsx file and close Excel. 

 
s. Add new .xlsx to your ArcMap session and join onto the hexagons dataset by Unique_ID, 

by right clicking the dataset, clicking Joins and Relates > Joins 
 

t. You can now export the hexagons to a new shapefile to make the join permanent, by 
right clicking on the dataset and clicking Data > Export Data. 
 

 
You should now be able to shade the hexagons by species number in the new exported file. 
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The dataset can then be symbolized and placed in a map layout as in the example below 
 

Example Map 

 
 
 
 
 
 

 


